banner

Announcement

Collapse
No announcement yet.

Annoying problem w/ egnater rebel 30 amp head

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Re: Annoying problem w/ egnater rebel 30 amp head

    Originally posted by SB1 View Post
    Okay, so no real advise from Egnater but to get it serviced at their one certified repair shop here in SD. Otherwise I can drive 3hrs north and take it directly to them.. After reading some poor reviews for the audio repair shop on Yelp, I'm thinking of taking on this repair myself. I'm going to start with new power tubes and making sure they have good connections.

    Found this writeup on line saying there were a couple bad tube connections.
    http://www.aaronbrownsound.com/repla...ube-combo-amp/

    Wish me luck!
    Go for it.....if you need a tech, send me a PM, and I will give you a few names with their location.
    good luck
    https://www.youtube.com/watch?v=gY73mb28orM
    https://www.youtube.com/watch?v=35mZ4BAvEbg
    https://www.youtube.com/watch?v=nToonE52DG8
    https://www.youtube.com/watch?v=XMl-ddFbSF0

    Comment


    • #32
      Re: Annoying problem w/ egnater rebel 30 amp head

      Hey guys. I just repaired one of these a couple of weeks ago. Same issue. Only this guy's amp was spitting fire. It happened only when he added el84 to the mix and only at loud volumes. Turned out to be a couple of wires on the output transformer. The board where the wires are connected are silk screened with the color of wire that slips onto a spade lug. Well, somebody switched a green and orange wire and it threw the output impedance out. So if he had it on 4 ohms it was probably really 16 or something. That also sounds like what has already been mentioned, cracked/cold solder joints or a bad cap.

      Comment


      • #33
        Re: Annoying problem w/ egnater rebel 30 amp head

        Egnaters seem all very reliable overall except the Rebel series.
        I've read lots of issues with those.
        Epiphone LP Standard PlusTop Pro
        Ibanez SZ320 / A8 DD103 bridge.
        Ibanez RG270 / Screamin' Demon bridge.

        Egnater Tweaker 15 Head / Laney Cub 8 / 2x12 - Celestion V30+K100
        Line 6 M13 and plenty of stompboxes I rarely use!

        Comment


        • #34
          Re: Annoying problem w/ egnater rebel 30 amp head

          Originally posted by Diego View Post
          Egnaters seem all very reliable overall except the Rebel series.
          I've read lots of issues with those.
          Not being argumentative, however, much of the recent egnator line has suffered from reliability questions. Look on tgp and other sources.

          Comment


          • #35
            Re: Annoying problem w/ egnater rebel 30 amp head

            I too had intermittent problems with my Egnater Rebel 30 combo. There was the sound of radio-like interference and the sound cutting out. Mostly when warming up the amp but sometimes in the middle of nowhere.

            It appeared to be related to the tone knobs, a little wiggle of the treble or bass on Ch 1 and it might reconnect.

            After reading this thread, I tried plugging in a cable, effects loop out back to loop in. Presto. All is well. I sprayed some contact cleaner up inside the two jacks and so far the symptoms have not returned, even without the cable jumping the effects loop.

            In all my years I've never heard an intermittent problem due to tubes. Thanks to all.

            Comment


            • #36
              Re: Annoying problem w/ egnater rebel 30 amp head

              I had a similar issue with mine.

              First thing I did was change the tubes. But it didn't help although when the amp worked properly it sounded really good.

              One day it just stopped working all together. I took a look on the inside and found the power tubes weren't getting power. Turned out one of the push on connectors from the transformer came unseated. I put it back on and never had a problem since.

              Comment

              Working...
              X