banner

Announcement

Collapse
No announcement yet.

Well I think I just junked my second amp this week.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Well I think I just junked my second amp this week.

    F M L!

    Now my XXL is dropping volume!
    When I chug with a palm mute, it drops volume, if I hit say a 3rd or 4th string, it brightens back up to full volume.

    It does it at 100w, 50w, and the lowest setting.
    It does it set on tight, medium, and loose.
    I took my cabinet back off to inspect if something was loose hoping it may just be speakers or something..... Looks all tidy in there ....

    It's like when it hits a certain freq, it drops out... Like it's vibrating something loose at those spots

    Uploading a video to show it.

    Whatcha think?

    I've never had any issues with amps untill about 10 days ago.... Marshall took a smoking dump, and now this one is limping for some reason.
    Last edited by 80's_Metal; 04-06-2019, 05:43 PM.
    Go buy my book. https://www.amazon.com/dp/198405564X

  • #2
    Re: Well I think I just junked my second amp this week.

    https://www.ultimate-guitar.com/foru....php?t=1249651

    I just read through this...hmmmm might give these effects loops ideas a try and see if it helps.
    Go buy my book. https://www.amazon.com/dp/198405564X

    Comment


    • #3
      Re: Well I think I just junked my second amp this week.

      Go buy my book. https://www.amazon.com/dp/198405564X

      Comment


      • #4
        Re: Well I think I just junked my second amp this week.

        I messed around with the effects loop volume button...I could hear it changing back and forth!

        I guess I need to pull it apart and solder some loose connection...but I'm too drunk to try tonight.... Maybe tomorrow.
        Go buy my book. https://www.amazon.com/dp/198405564X

        Comment


        • #5
          Re: Well I think I just junked my second amp this week.

          Give your tone controls a spin .
          sigpic

          - http://www.soundclick.com/bands/defa...?bandID=804435 -
          - https://soundcloud.com/mr-ds-bigband/tracks -

          Warning: May contain traces of NUTS

          Comment


          • #6
            Re: Well I think I just junked my second amp this week.

            I recently had a volume drop issue with my Blackstar. It was also somehow due to the fx loop. I worked the switch in and out a few times and it seemed to correct the issue.

            How old are the power tubes?

            Comment


            • #7
              Re: Well I think I just junked my second amp this week.

              Originally posted by 80's_Metal View Post
              https://www.ultimate-guitar.com/foru....php?t=1249651

              I just read through this...hmmmm might give these effects loops ideas a try and see if it helps.
              Was about to suggest just that. Quick way to chek if it's an issue is to drop a short jumper in the loop and see if the issue dissapears. What can happen over time is the jacks corrode because they are never used then don't bypass the signal properly due to the corrosion. Causes exactly the issue you are describing.
              Hit the jack with contact cleaner then insert a jumper in and out a few time before leaving it and see if the problem goes away. If it does then ether clean or replace the jacks which ever it takes.
              Last edited by Ascension; 04-06-2019, 08:12 PM.
              Guitars
              Kiesel DC 135, Carvin AE 185, DC 400, DC 127 KOA, DC 127 Quilt Purple, X220C, PRS Custom 24, Washburn USA MG 122 proto , MG 102, MG 120.
              Amps PRS Archon 50 head, MT 15, Mesa Subway Rocket, DC-5, Carvin X50B Hot Rod Mod head, Zinky 25watt Blue Velvet combo.

              Comment


              • #8
                Re: Well I think I just junked my second amp this week.

                Originally posted by 80's_Metal View Post
                I messed around with the effects loop volume button...I could hear it changing back and forth!

                I guess I need to pull it apart and solder some loose connection...but I'm too drunk to try tonight.... Maybe tomorrow.
                It's likely not connections in solder joints but dirty contacts ether in a switch or jacks.
                Guitars
                Kiesel DC 135, Carvin AE 185, DC 400, DC 127 KOA, DC 127 Quilt Purple, X220C, PRS Custom 24, Washburn USA MG 122 proto , MG 102, MG 120.
                Amps PRS Archon 50 head, MT 15, Mesa Subway Rocket, DC-5, Carvin X50B Hot Rod Mod head, Zinky 25watt Blue Velvet combo.

                Comment


                • #9
                  Re: Well I think I just junked my second amp this week.

                  I plugged **** in and out into every hole I could find like a drunk sorority girl!

                  I think I've narrowed it down to the effects volume switch. I've got it on the bench right now, my dru ass is rocking my old Valvestate 2000 at the moment... The one that hums and the effects are either on or off, disregard the footswitch ha ha ha....
                  Go buy my book. https://www.amazon.com/dp/198405564X

                  Comment


                  • #10
                    Re: Well I think I just junked my second amp this week.

                    God help that valvestate. Its days are numbered.

                    Comment


                    • #11
                      Re: Well I think I just junked my second amp this week.

                      I recommend you find a Sovtek Mig100 head - probably the Mig100H variant if you can (given you like the higher gain flavours).
                      Then whilst the others are getting fixed you'll have a bullet proof back up that kicks some serious ass. Not sure what these fetch in the US, but here in Australia they're really cheap compared to Marshalls etc.

                      In the meantime, hope the XXL comes good without too much cash hemorrhage.. I'd always try the basics first, as others have suggested; contact cleaner and socket love. Good luck dude!

                      Comment


                      • #12
                        Re: Well I think I just junked my second amp this week.

                        I didn't get any time to mess with the XXL today.
                        But I bet it's the effects loop thing because I could make it repeat the volume drop by pushing the switch in and out....

                        I am going to sell off a bow, probably sell off a couple of amps, and then buy another amp...

                        Thinking katana or maybe carvin v3 or another 6505+ again.... We'll see.
                        Go buy my book. https://www.amazon.com/dp/198405564X

                        Comment


                        • #13
                          Re: Well I think I just junked my second amp this week.

                          My stereo rig was two XXL's. Over the years they never needed more than Deoxit to fix any issues like that. Hope you have similar luck!
                          I miss the '80s (girls) !!!

                          Seymour Duncans currently in use - In Les Pauls: Custom(b)/Jazz(n), Distortion(b)/Jazz(n), '59(b)/'59(n) w/A4 mag, P-Rails(b)/P-Rails(n); In a Bullet S-3: P-Rails(b)/stock/Vintage Stack Tele(n); In a Dot: Seth Lover(b)/Seth Lover(n); In a Del Mar: Mag Mic; In a Lead II: Custom Shop Fender X-1(b)

                          Comment


                          • #14
                            Re: Well I think I just junked my second amp this week.

                            Hopefully its something simple. Peaveys are normally bullet proof. Embarrassed to tell this, but I will. Not long after I got my Splawn, I learned you could use the effects loop like a master volume. So, was doing that to get the tone at lower volumes.. I then moved it out to the garage (Cuz we moved to house with a garage) I was able to play alil louder.. I kept getting this awful noise when Id chunk lower chords. I took it to a shop. Tech went thru it a couple of times.. Retubed it, etc.. He couldnt replicate the issue. Basically, since I was playing it louder, I needed to go back to normal as the loop deal wasnt made for playing loud and I guess it was overloading.. Switched to normal and all was fine.
                            Im sharing this to say that perhaps and hopefully it is something simple, like a setting
                            Believe me when I say that some of the most amazing music in history was made on equipment that's not as good as what you own right now.

                            Jol Dantzig

                            Comment


                            • #15
                              Re: Well I think I just junked my second amp this week.

                              Comment

                              Working...
                              X