banner

Announcement

Collapse
No announcement yet.

Case of a Missing Clean Channel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Case of a Missing Clean Channel

    Hi all!

    I assume some of you have 5150 iii heads. I have a 50 watt el-34 version and the clean channel does not make any sound regardless of where the gain or volume is set. The blue and red channels are fantastic.

    I have included a link where I mistakenly refer to channel 1 as blue. It is green.

    Thank you!

    https://youtu.be/x-CNolKBogg

    Sent from my iPhone using Tapatalk
    Nsatke81
    Tone Member
    Last edited by Nsatke81; 01-13-2022, 01:39 PM.

  • #2
    Don't know the tube complement of that particular amp but perhaps a bad V1 preamp tube? Swap 'em around and see if the problem moves.

    Comment


    • #3
      is there hiss or hum? does it get louder as you you roll the volume up?

      Comment


      • #4
        Ch1 & 2 have dual concentric knobs. The clean channel is the outside "ring" of the two knobs. The chicken head portion is for the blue channel. Are the outer rings turned up?

        Comment


        • #5
          Originally posted by jeremy View Post
          is there hiss or hum? does it get louder as you you roll the volume up?
          No it’s just dead silence no matter what happens to the gain or volume knobs.


          Sent from my iPhone using Tapatalk

          Comment


          • #6
            Originally posted by CipherArcher View Post
            Ch1 & 2 have dual concentric knobs. The clean channel is the outside "ring" of the two knobs. The chicken head portion is for the blue channel. Are the outer rings turned up?
            Winner! No idea how I didn’t spot this. My 6L6 does not have this feature but I love it!


            Sent from my iPhone using Tapatalk

            Comment


            • #7
              Sweet!

              Comment


              • #8
                Congrats on your new amp! Not the one that didn't work, but the one that has the killer clean channel. (just being a wise*ss lol)

                Comment


                • #9
                  Originally posted by dave74 View Post
                  Congrats on your new amp! Not the one that didn't work, but the one that has the killer clean channel. (just being a wise*ss lol)
                  It is indeed a killer! It’s funny playing the 6L6 and EL34 back to back, I thought they would sound more different. The amps still have a very similar character, but the flavor is different. The feel is comparable.


                  Sent from my iPhone using Tapatalk

                  Comment


                  • #10
                    I do love it when fixes to fairly expensive amps are that easy.
                    Dave, Ambassador/Writer/Artist for Seymour Duncan

                    Comment

                    Working...
                    X