banner

Announcement

Collapse
No announcement yet.

Wah help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • blueman335
    replied
    Re: Wah help

    Originally posted by d1dsj View Post
    Cheers Rick. Yes I've opened it up, can't see anything obvious and I have started carefully picking off all of the red rubberised coating that's on the board. But so far as I say I can't see anything untoward. I will contact Jeff and see what comes back as this Wah does have its place in my rig.

    Good plan. You've got an excellent wah, just needs a minor fix.

    Leave a comment:


  • d1dsj
    replied
    Re: Wah help

    Cheers Rick. Yes I've opened it up, can't see anything obvious and I have started carefully picking off all of the red rubberised coating that's on the board. But so far as I say I can't see anything untoward. I will contact Jeff and see what comes back as this Wah does have its place in my rig.

    Leave a comment:


  • blueman335
    replied
    Re: Wah help

    First suspect would be the switch wearing out. They don't cost much, just wire the new one like the old one. Other culprit could be the pot, but that's less likely, especially if it wasn't had a ton of use. What's going to wear out on a wah is the moving parts. Everything on the board should be fine, unless it's gotten an electrical surge. Have you opened it up to see if anything looks or sounds odd?

    Your best bet is to contact RMC and tell them what's going on. You won't be the first person in the world to have experienced what you have.

    Leave a comment:


  • d1dsj
    replied
    Re: Wah help

    Thanks for the reply PFD, yes I did and I sprayed a little contact cleaner too just in case. I have in the past had a Wah switch that didn't engage at all so when I activated there was no sound at all.... So you think it could be a dodgy switch?

    Leave a comment:


  • PFDarkside
    replied
    Re: Wah help

    Did you cycle the switch with your finger a few times? That's how some of my pedals sounded when the switch was broken. It's like one side engages but the other doesn't.

    Leave a comment:


  • d1dsj
    started a topic Wah help

    Wah help

    I hadn't used my Wizard Wah for a while and yesterday whilst messing with my board and comparing some pedals it threw a wobbler. When I stomp on it to turn it on it goes into an almost half cocked mode, it is activated and sounds like it's stuck in the lower frequencies of the sweep. Operating the foot plate does nothing to change the tone? The switch is working so is this likely to be the pot or the fasal? I have opened it up and checked that the gears are ok and that there are no missing or worn teeth and that the bar is making a good connection to the cog..... All seems Ok?

    Any help appreciated.
Working...
X